Cloudflare and ConvertKit not Verifiying

Hi,

I have created three A records on cloudflare and connected the 3 IPV4 addresses from ConvertKit.
It has been over 24hrs now and the status is being verified.

I have also created a CNAME record, which I set the name is www and content to my domain name.

The 2 Cloudflare name servers are: meera.ns.cloudflare.com and jim.ns.cloudflare.com.

Is there something, I may have missed whilst setting this up as I have looked through the other questions and it seems to worked for others.

If the records need to be verified then make sure they are set to “DNS only” and not “Proxied” so they are publicly viewable.

Otherwise, what is the domain and records you have been asked to set?

1 Like

Hi, thank you for getting back to me.

If I turned off the proxies, it worked but turning them back again it stopped working.

I might be wrong but I read somewhere that turning on proxies its best practise on cloudflare.

Here is the domain : www.Seraphineyoung.com

There are 3 IP address that I need to create A records for.

You have “too many redirects”…
https://cf.sjr.org.uk/tools/check?2517671ef1ad444bbe08b7ca2789de80#connection-server-http

Check your SSL/TLS setting is set to “Full (strict)” in your dashboard here…
https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls

1 Like

Hi,

I have set SSL/TLS setting is set to “Full (strict) and then turned the proxies back on.

Bumping into a new error:

“SSL certificate presented by the server did not pass validation”

Still showing Unverified from ConvertKit, it seems to only work when I turn the proxies which isn’t best practise I believe ?

If the host requires your records to be validated then you will have to use the DNS record with “DNS only” instead of “Proxied”. Often this is done to issue SSL certificates.

You can try to turn the proxy back on after validation, but it may stop again if they continuously verify the settings, or need to update the SSL certificate later so you can only test it and see. If it only works with “DNS only”, then that’s how you’ll have to leave it.

1 Like