Cloudflare adds 200 random records when adding a domain

My question seems the same as this, which was not resolved.

I just added a domain with 4 DNS records, but Cloudflare somewhat added 200 random records. I don’t have any wildcard records as the server does not support it. This looks like there’s been an ongoing bug with Cloudflare DNS setup procedures.

I’d prefer to hide it from public. Is there a way to share this directory with CF staffs?

I found a temporary solution, which is to delete the domain and add again as described in here.

Here’s another related topic for reference.

For any future users who may face this trouble, here’s the soluion.

Keep deleting and adding again and again until CF scan’s the correct DNS records.

For the domain in trouble, I repeated 3 times, and finally CF scan was able to properly handle 4 existing records.

Can you email [email protected] from your account email with the details and the domain this happened for. When you get an autoresponse please post the ticket number here.

Some possible workaround ideas:

The scanning tool is the best effort attempt at identifying existing DNS records, and whether it works is entirely dependent on your current Authoritative DNS provider’s response to DNS queries.

Even if you did not create the records, the existing or former Nameserver provider responded to those queries with an IP address or CNAME value.

Let’s say that you never created the FTP subdomain, ftp.example.com, but when we query for this record, the DNS provider responds with an IP of a parked/block/error page. The record would still be added to your DNS settings, this is expected.

Our documentation is getting moved a bit lately, and I’m not finding the article we had in place about DNS Scans, these are some of the references I found:

If you want more control over which DNS records are imported and how, use the bulk imports .

Scan for common DNS records on your domain and automatically add them to your zone. Useful if you haven’t updated your nameservers yet.

4 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.