Cloudflare activated but site still displays Let's encrypt

Hello! This is about the site {redacted}

My domain is pointing to cloudflare, orange cloud enabled. Flexible ssl mode, and despite that, it still displays Let’s encrypt and not cloudflare. Even after 24 hours of waiting.

I also tried the Strict mode by adding the cloudflare certificate on my server, but same result.

Any idea ?


That’s never good.

That’s much better, but please use Full (Strict). Cloudflare uses Let’s Encrypt at the edge as well as their own Cloudflare/DigiCert certs. Your browser’s Dev Tools (F12 in Chrome) will show you in the Network tab if a request is using Cloudflare (Click on a file after your site loads and look at the Response Headers).


Ok it’s done, I just switched to Strict mode. But I had already done this test and I think it didn’t change anything, I still have Let’s encrypt at the certificate level.

I also enabled “Authenticated extractions from the origin server” which should normally display an error on the site if I haven’t set up the server side certificate. Even though I didn’t install the certificate, the error doesn’t appear.

Really strange, maybe I should wait another 24 hours and see if there is a change?

No, it’s the other way around. Cloudlfare can send a cert to anybody. But if your server isn’t set up to require certs, it won’t care of the request includes one or not.


Thank you very much, it’s clearer to me now.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.