Cloudflare Access / Zero Trust Instant Auth greyed out

Hi,

Recemtly I have implemented Cloudflare Access / Zero Trust for my services with Google as OAuth provider. I’m really pleased with this solution as it works wonderfully as SSO. Last week I also wanted to enable Instant Auth, as I only have a single auth provider.

First I’ve tried to enable it within the App Launcher > Authentication setting, but there the Instant Auth setting is grayed out and I cannot seem to enable it. Than I’ve tried to enable it in Access > Applications > {Application} > Authentication, but there it is the same.

I’m unsure why I cannot enable this option. Am I missing something or is this a perhaps a bug?

Can you post a screenshot of this section?

HI Eric,

Thanks for your response. Here are the screenshots of my environment / configuration:

  1. Here you can see I have a single Authentication provider as per the docs
  2. Within the App Launcher configuration, the Instant Auth option is greyed out, and I’m unable to switch it to on
  3. And it’s the same on the self-hosted Application authorization configuration, for example:

Am I missing something?

Hmm, are you still required to choose an identity provider to authenticate when you try to access a Cloudflare Access protected application, even though Google is the only IdP that you’ve configured?

Correct. When I go to the URL for my Grafana instance when I don’t have an active session I get a IdP selection screen, like this:

Sigh, I’ve got it working… On both applications and on the App launcher. The Instant Auth option is still grayed out:

But… After clicking on the Google IdP (while it is selected), the Instant Auth option becomes available:

And I can enable it:

image

Thanks for your help and patience @erictung. but I guess this is just a weird bug :confused: