CloudFlare Access - Unable to find the requested identity provider!

I have tried adding two separate login providers, Azure AD and Github. I followed the directions explicitly for each. Unable to test either successfully. When I click the test link for each, I receive the same error:
“Unable to find the requested identity provider!”. In addition, when accessing a defined application that has both providers enabled, I get the default Cloudflare Access login page that wants to email a login code, even though I have deleted the default OTP login provider. Any thoughts? Greatly appreciated!

1 Like

That sounds quite unusual - can you screenshot the config you have?

Easier to include links to the documentation I followed including screen shots.



Followed these directions for Azure AD… Microsoft Azure AD® · Cloudflare for Teams documentation

and these for Github… GitHub · Cloudflare for Teams documentation

When I click to test either iDP, I get the same error (previously stated) for both.

That’s strange - can you please try modifying your applications - make a quick change to the domain (to anything) and save. Then change it back to the real domain and save again for me?

Can you be more specific?

I tried changing the teams domain. Before changing it back, I get an endless spinning circle in the body of the page. If i chnge the teams domain back to what I originally had, then when accessing it, I get " Please contact your administrator to enable the Access App Launch on your account". Even though “Access App Launch” is configured, I cannot access it. If I try to customize the login page by changing the background color, it never takes effect. It all seems to be related to not being able to access the teams domain page.

Hi,

Would you mind confirming with us if the problem it’s still happening, i’ve just checked my access application and working without any issue;

thanks in advance

Not sure about OP, but I am having the same issues. It’s happened since I set up Access last week. If I try to test the GitHub provider I get the “Unable to find the requested identity provider!” error, and if I try to navigate to the App Launcher it says " Please contact your administrator to enable the Access App Launch on your account".

I’ve tried a couple of different combinations of rules, from my IP to everyone, in both the app itself and the launcher, but none seem to work.

Hi @bdub and @wayofthepie,

Looks like it’s related to this incident, please track the status there.

Thanks @domjh that seems to have been the issue. Strange as it wasn’t working last week either, I wonder if there was an issue then also when I was setting it up. Everything is good now for me.

No problem, glad it’s working for you now. Thanks for reporting the issue, just let us know if you have any more problems.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.