Cloudflare 524 - PHP version?

I reported an issue last week - where I get Error 524 whenever I try and use a wordpress site or try and create a new page etc.

My hosting company use php 7.0.15 (which is no longer supported) and they some way behind in upgrading to php 7.4

Would Error 524 be caused by the version of php ?

Only if PHP7.0 is so slow it causes the timeout. 7.4 should be faster, but if your server is super slow, even that might not be enough.

A 524 error indicates that Cloudflare made a successful TCP connection to the origin web server, but the origin did not reply with an HTTP response before the connection timed out. Review the suggestions in this Community Tip for troubleshooting ideas.

1 Like