Cloudflare 523 error after set up let's encrypt SSL

I would pause Cloudflare - Pause Cloudflare · Cloudflare Fundamentals docs - and check if the site loads fine on HTTPS without Cloudflare. If not, you will have to fix your server. If it does, you will have a firewall in place which blocks Cloudflare and need to adjust that.

But how can I let go of the firewall for Cloudflare?

Cloudflare’s firewall is not the issue. Did you follow the steps I mentioned?

I disable my vps’s firewall ansd it works, but how can I set only bypass Cloudflare’s visit?

You have not paused Cloudflare.

Yes I did not pause Cloudflare cos I want to use it’s DNS service and I disable my firewall from VPS and it works. And now I am trying to add ip6tables -I INPUT -p tcp -m multiport --dports http,https -s 2803:f800:: -j ACCEPT someting like this to add Cloudflare’s ip to go through my firewall, but it seems help nothing

Well, if you don’t follow the given advice, it’s unfortunately not possible to make any further statement except for pointing you to the general article.

Your server is blocking Cloudflare and that’s why you are getting the error. You need to reconfigure your server.

OK! I paused Cloudflare and can not access my site! So now how to solve this problem?

Precisely what I wrote hours ago.

Considering that it does not load, you need to fix the server.

Yeah cos now te problem is I don’t know how to fix it cos I am a newbie… :sweat_smile:

My personal advice would be not to use a public server if you don’t have the proper knowledge yet. Better use a managed service. You can get the necessary expertise with a local machine, once you feel comfortable you can certainly manage your own server as well.

As for the issue here, your server is not responding on HTTPS and you will need to fix that. Unfortunately, server administration is beyond the scope of the forum here and I would refer you to more appropriate forums like StackExchange or Reddit.

Thanks mate! But now it works after I pause and enable Cloudflare and flush my iptables firewall rules. Thank you for your kind help.

Yes, it appears as if your server now responded to HTTPS.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.