Cloudflare 403 error on sitemap google search console

Hi guys,

I need help in solving 403 error when submitting sitemap. As you can see my website is asuransimurni.com and i think we’re able to access the following url through browser
https://asuransimurni.com/sitemap_index.xml

I tried to change the useragent in my firefox into “googlebot” and still able to read the sitemap_index.xml. I’ve searched all over the File Manager and i didn’t find any sitemap_index.xml physical files.

I tried to disable Cloudflare (by switching the nameserver into default instead of using cloudflare nameserver) and resubmit, it returns success.

Clouflare has been really useful to me and my reader, and i need my sitemap to cooperate with google search console.

Since i am quite new on this, please advise what should i do.

Thanks!

You should check out what the respective entry in the firewall event log says. That should give you a hint as to why it was blocked (if it was actually blocked by Cloudflare).

Sitemeer can access the file just fine and Sitemeer does not go in with a desktop user agent

sitemeer.com/#https://asuransimurni.com/sitemap_index.xml

hi @sandro i can confirm you that there were no Googlebot user agent in my firewall activities. Does it mean Cloudflare didn’t block Googlebot?

In that case, why the Googlebot worked properly when i disconnected the cloudflare?

what do you suggest me to do next?

If there is nothing in your Cloudflare logs, it is unlikely Cloudflare blocked anything. Also, by default Cloudflare has Google whitelisted.

I’d say you should check your server logs at this point.

I’d say you should check your server logs at this point.

i just got an email from my hosting administrator. They advise me to disable modsecurity in my cpanel, which i did by now and voila! GSC is able to read my sitemap.

Thanks a lot @sandro it really helps!

This topic was automatically closed after 30 days. New replies are no longer allowed.