Cloudflare 301 status code for http redirect and POST method not working for the API url which migrated to cloudlfare

Team,

We are facing issue with http redirects for the POST method for our API endpoint which migrated to cloudflare.

We were using nginx ingress to handle the http redirects to https and it responds with 308 status response code. We were testing the POST http method using http and https both for the api URL.

Now after migrate to cloudflare, we are getting 301 status response code for http redirects to https. hence we are not able to run POST http method and it getting changed to GET method. so now we can only access with https not http.

Using http with POST method is not working for the API URL which we migrated to cloudflare. How to achieve this ?
We need to use http and https to access the API using POST HTTP method.

You might need to disable “Always use HTTPS” feature in Cloudflare SSL/TLS tab.

This will impact other endpoint in that zone, We need the SSL feature that is the main concern we migrated to cloudflare.

Is there any way to create page rule for this specific endpoint?

Can you elaborate? Considering you need a certificate on your server, you won’t get anything in addition here anyhow.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.