Cloudflare 1.1.1.1 dot tk domains not resolved

I am from india and i am using cloudflare 1.1.1.1 i found that all dot tk domains arw not gettong resolved they are ahowinf nx domain error. I tried wirh google dna all sites are working fine. Seems to be cloudflare specific. My isp is airtel.

Do you have a list of specific .tk domains that are not resolving for you with 1.1.1.1?

Even dot tk offical site is not working for me.

dot.tk
my.dot.tk

Seems to resolve just fine for me when using 1.1.1.1.

$ dig @1.1.1.1 dot.tk

; <<>> DiG 9.16.1-Ubuntu <<>> @1.1.1.1 dot.tk
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 57732
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;dot.tk.                                IN      A

;; ANSWER SECTION:
dot.tk.                 7200    IN      A       35.186.233.234

;; Query time: 10 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Tue Jan 04 21:53:36 CET 2022
;; MSG SIZE  rcvd: 51

Do you have any more information that indicates that .tk domains are not resolving for you when using 1.1.1.1?

I am not sure i think its region specific only in india.

I have attached for same result one with google dns and other with cloudflare dns. You can see cloudflare dns has empty a record.


Hm interesting to see that it took there several seconds for the DNS query from 1.1.1.1.
What happens if you try querying with 1.0.0.1 instead?

Same issue here in Pakistan… No .tk domain getting resolved

Same issue with 1.0.0.1 and similar query time as well.

Looks like the issue is resolved…i can resolve .tk domains from cloudflare now

Can confirm its fixed now. It was an issue for like 24 hours.

Not sure what was the cause for this issue.

Hi,

If you look into the OPT=15 line, it indicates the extended error is 22(0x16), it was somehow that in some region, our server was not able to reach the dot.tk name servers.

1 Like

I figured that the default dns servers of my isp airtel were also not resolving dot tk domains So somehow airtel was responsible for the issue and i think cloudflare also uses the same routes that might have been the issue.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.