Cloudfare "Verify you are human" keeps failing

I’m honestly not sure I’m even asking in the right place, but I can’t seem to find answers anywhere. I don’t know anything about this community, and I only made this account to post this question. But any website that uses Cloudfare to verify I am a human will NOT work not matter how many times I attempt to verify. I can’t access important websites I need for work because of this, unless I am using an incognito tab. For some reason, if I am in incognito mode, it works fine. Does anyone know how to resolve this? I’m at a loss and I’m getting increasingly frustrated.

I had this problem yesterday (and started another thread about it here). I agree it’s very frustrating. In my case, after I tried it in an incognito window and it worked, it started working in my normal window too, so now I can’t reproduce the issue. I take it that’s not happening for you - it continues to not-work in the normal tab?
I have not yet found out what this check is actually trying to check. Knowing that would help debug the issue.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.