Cloudfare SSL to Azure App Service instance - enable HTTPS?

Hi - I have my new cloudfare SSL working on my test domain lopezdemo - dot - net. When I enter https://lopezdemo.net in the browser, it shows locked. When I enter lopezdemo.net, it shows “not secure.” In the Azure portal is sees my custom domain and it’s asking me add bindings and upload a .pfx certificate. I didn’t think I needed to install anything on my hosting instance. Where can I download my cert? I have the free SSL plan.

Hi - Ok I went into my cloud fare SSL panel and changed the SSL from Full to Strict. When I reloaded the page and also in an incognito page, it said invalid certificate. When I changed the SSL from Strict back to Full, the original problem went away and not the root domain shows the lock! strange. I didn’t make any setting changes on the Azure side.