Cloudfare not speeding up things when doing a manual setup through creating account

I have enabled cloudfare 5th May evening 7pm but the load time is still more than 5 seconds and number of requests more than 50 to connect.Earlier when i had enabled cloudfare through my hosting company load time was half a second and number of requests made were around 4.
but there was some problem when enabling it from their end so had to do it manually.Why is it so?

1 Like

I see that even waiting for WordPress to redirect to www takes several seconds. This points to a delay in your server responding to Cloudflare requests, so it’s difficult to track down the problem without direct access.

If you’re not comfortable with ‘curl’, then you’d have to “Pause Cloudflare on Site” from the Overview page to see if the response delay is at your server.

i Sdayman,

Yes when i disable the cloudfare,there is considerable wait in loading the page.
I have recorded a HAR file.but there is no means to upload it here.Please help me in resolving this issue.

If TTFB load is slow without Cloudflare, it’s not going to be fast with Cloudflare. The HTML content still has to come from your web server, and if that’s slow, TTFB will also be slow. You’ll have to research how to speed up WordPress in general.

Cloudflare will speed up all the static files and lower the overall load time.

How much have it been before?
You can not compare things to “nothing”. To compare you need to test it before and after activating CloudFlare.

To boost a little bit, please:

  • set Browser Cache TTL to 1 year
  • concatenate CSS
  • concatenate JS
  • remove unsused CSS
  • remove unsused JS
  • prevent using external CSS
  • prevent using external JS
  • set up static caching as you site seems to be static.

Also: you do get 18 Errors due to missconfigurated CORS policy (this has nothing to do with CloudFlare)

Note: all of these things does have nothing to do with CloudFlare. I’m very sure your site have been slower before CloudFlare then it is now

2 Likes

Can you Please let me know what is this and how and where can i see and fix this?


The image shows the load time when Cloudfare was enabled from my hosting provider options page.Check the green ones.But that option ran into some problem at the hosting provider end it is being fixed.In the meantime i disabled that created a account on cludfare and set up the nameservers manually which is not reducing the time as it was before.

1 Like

What is before what after?

Please google this. CORS Policy can be set for example in .htaccess

2 Likes

Before is when there was no CDN configuration,load time of 1.9s,1.83s and 1.72 secs and after when CDN was enabled from my hosting provider CDN option and then the load time of 659ms and 778ms.

1 Like

But this exactly proofs that CloudFlare is indeed speeding up your site?
So I see no problem here as your Thread is called " Cloudfare not speeding up things"

1 Like

Sorry for such a late reply.I never doubted cloudfare but as i mentioned in the post when the CDN is activated by creating a account manually,its not as fast as for opting the CDN option from hosting provider dashboard(This option worked for a day but then the hosting provider had some issues with it and thats why i created a account and setup things manually).I was looking for the optimized settings.Thanks for all your support.

This topic was automatically closed after 31 days. New replies are no longer allowed.