Cloudfare, my website, I can not open it by domain name. Error 521

Answer these questions to help the Community help you get started.

What is the domain name?
my domain name: myewada com

Have you searched for an answer?
Yes, but I did not find solutions.

Please share your search results url:
No

When you tested your domain, what were the results?
101 . 32 . 245 . 229, I can open my website by IP. But domain name does not work.

Describe the issue you are having:

What error message or number are you receiving?
Error 521

What steps have you taken to resolve the issue?

  1. I tried to delete domain name from Couldfare. It works to open my website by the domain name.
  2. Then I add the domain name to Cloudflare, and modify the Cloudflare DNS in the donain supplier system.
  3. Then I can open my website by the domain name.

Was the site working with SSL prior to adding it to Cloudflare?
Not sure.

What are the steps to reproduce the error:

Have you tried from another browser and/or incognito mode?
Yes, I tried. Do not work.

I can reach your origin using WARP, but not directly so I guess you are firewalled to Cloudflare IPs only.

HTTP is ok, HTTPS seems to have some SSL issue that’s throwing cURL out at my end.

curl -I http://101.32.245.229 -H 'Host: myewada.com'
HTTP/1.1 200 OK
Server: nginx
Date: Mon, 20 Nov 2023 16:13:03 GMT
Content-Type: text/html
Content-Length: 138
Last-Modified: Mon, 20 Nov 2023 09:49:29 GMT
Connection: keep-alive
ETag: "655b2ba9-8a"
Accept-Ranges: bytes
Cf-Team: 1c8f1ad0f2000065116048b400000001

curl -Ivv https://101.32.245.229 -H 'Host: myewada.com' --insecure
*   Trying 101.32.245.229:443...
* Connected to 101.32.245.229 (101.32.245.229) port 443 (#0)
* ALPN: offers h2,http/1.1
* (304) (OUT), TLS handshake, Client hello (1):
* LibreSSL SSL_connect: SSL_ERROR_SYSCALL in connection to 101.32.245.229:443
* Closing connection 0
curl: (35) LibreSSL SSL_connect: SSL_ERROR_SYSCALL in connection to 101.32.245.229:443

yes, by http ip URL, I can open it.

But by domain name: myewada .com

No matter http or https, both I can not open it.

Could you please teach me how to solve it.

God bless you. Thanks

Your origin server seems to have a problem with SSL or its HTTPS configuration. You need to check and fix that since Cloudflare cannot connect to your origin for the same reason.

Also check if you are restricting access in your firewall to just Cloudflare IPs, you have all of them…

Yes, I ever apply SSL certification for my domain from our domain supplier.

But I found that Cloudflare provide SSL for my domain,too. So I used Cloudflare, I did not use the other SSL certification.

So firstly, I need to delete all other SSL certifications? Just keep Cloudflare?

Secondly, how to check my firewall IP setting issue? Actually firewall, it seems that it can limit ports, it can not limit IP.

And I tried to open the link: www . myewada . com not matter https nor http, both I can not open it.

It shows error 521 from the host. I really do not know what happened. :sob:

Yes you need a certificate on your origin server. That is needed for secure connections to your server from Cloudflare.

This is because if your SSL/TLS setting is set to Full or Full (Strict), then Cloudflare will always connect to your origin using HTTPS, even if you connect to Cloudflare by HTTP.

You can try to set your SSL/TLS to “Flexible” then Cloudflare will only connect to your origin by HTTP (even if users connect to Cloudflare by HTTPS) but then your connection is not secure between Cloudflare and your origin.

See here…

Is there anything that I set wrong?

I seems I have followed your advice, and I set the same as you said. But actually, I still can open

the URL by: http: // www . myewada .com nor, https: // www. myewada . com

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.