Cloudfare Blocks my access

I have attempted to look up documents and connect for support to the Maricopa County Recorder’s office in Arizona. The webpage states that it is provided by Cloudflare. The page repeatedly states it is attempting to determine if the connection is secure. This continues over and over and the site does not let me in to perform my required tasks.
I have tried 4 different browsers. Same result.
Maricopa County Recorder’s Office refuses to help. They state I am the only one with a problem.
Well, I have current antivirus and have never had these issues before. Is there a fix?

Terry

You could try a VPN or see if you can get a different IP from your ISP. Do you have any ad blockers running in the browsers? If so, disable it and try again.

Thanks, I will give it a try tomorrow. I’ll let you know:)

Thanks…

I disabled my anti-virus etc just to see if that had any effect.

It made no difference.

I will try a VPN… I have little choice on internet as I must work with a wireless connection in my current apartment location.

I will pull out my old laptop this weekend and try that too.

Thanks again,

Terry

FWIW @tmajor I am able to access the site without issue and I am outside the U.S.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.