Closed the connection

I’ve been trying to link my Dynmap to my domain. I used an A record (proxied) with Flexible SSL. When I visit it, it always says Closed Connection. But when I visit it using the IP, it works. Dynmap is on the 9999 port, I might add a Page Rule redirect or something soon. But for now I just go there manually.

I am not sure, but maybe it should work with one of the compatible and supported ports with Cloudflare from the list on the below article (link)?:

This should be fixed as follows from below guide:

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare CA Origin Certificate:

I cannot add SSL to the Dynmap, and I can’t change my port either. So none of these are gonna work for me.

Ough, that’s a bad one for starting point :frowning:

How about this from below?:

May I ask due to what?
Your ISP blocking / restricted some ports or?

Well, there could be a few possible ways.
Like, for example to setup an reverse proxy - that is, the nginx of apache server, on port 80 or 443 - is set up to forward requests to the dynmap internal web server?

Gist for Nginx Web server:

Maybe using Kemp Load Balancer?:

More help:

From below, both articles aren’t helpful neither?

Otherwise, I am afraid you are a bit in “so-so” situation here.
And the only possible way is to have that A record unproxied :grey: (DNS-only) to make sure it works over the desired port.

I’m using a Minecraft Host that doesn’t allow me to specify what port will be assigned. (for obvious reasons) and I can’t install other stuff on the server since it only allows me to use it for Minecraft. And if i use DNS-only I don’t have SSL which defeats the whole reason why I moved it to Cloudflare.

I’m not asking how to link my server, I already did that.

May I suggest below posts in this case:

Both of them cannot be used since I can’t install Nginx, and I specify the port.

Then I am really sorry to say, but currently I do not have any other idea :confused:

Kindly and patiently wait for someone else’s reply with more helpful information and experience, if so.

1 Like

Then I would suggest you get another host, as @fritex already said, your current setup is broken and won’t properly work.

And the Minecraft thing is not clear to me either, because you won’t be able to proxy Minecraft, unless you sign up for the expensive Pro Spectrum and if you can afford that you can afford your own secured data center :wink:.

I don’t need proxy for Minecraft, and the current host is good. I just wanna know how can I fix the Closed the connection problem.

If your host does not provide SSL, it obviously is not good.

The host has nothing to do with Dynmap. Dynmap doesn’t support SSL.

Then you best keep this on HTTP.

So there isn’t anyway I can make it SSL using Cloudflare?

Your software needs to support SSL for that.

Ok, thank you. I’ll try setting it up with an external webserver.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.