Clodflare SSL/TLS Handshake errors

I can’t connect to my site with SSL/TLS Enabled because every browser finds a Handshake error. I tried to diagnose the site using the Cloudflare Diagnostic Center and it also found a Handshake error.

The domain is lab38.xyz and I have been testing with echo.exp.lab38.xyz.
If you try to access it using plain http it will work just fine.

I have tried to access the site from different browsers, different devices on different ISPs and I had the same issue.

I’m assuming this is not a Browser/Client issue since the Cloudflare Diagnostic Center is also reporting the same issue.

Find below a screenshot of the report from Cloudflare Diagnostic Center about the SSL/TLS Certificate:

This subdomain is two levels deep and won’t be covered under Universal SSL. You need to purchase Advanced Certificate Manager and create a certificate for *.exp.lab38.xyz or unproxy (:grey:) the record.

1 Like

So If I change the domain to echo.lab38.xyz is it supposed to work?

Yes.

Universal SSL covers *.example.com and example.com

Thank you. I confirm. I have made the change and it is now working Just fine

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.