Clodflare proxy not working for allowed port (2095)

Hi,

I know many people have asked about custom ports, but I already read the list of supported HTTP/HTTPS ports. My server is running an HTTP service on 2095 and HTTPS on 2096. I created a DNS record with proxy enabled. The https app works fine (I can see Cloudflare’s SSL certs in certificate details from browser). but when I try to connect to port 2095 it redirects me to http://mydomain.com:2095 -> https://mydomain.com. Since nothing is listening on 443 I get a 521 error. As per allowed ports, 2095 over HTTP should work with proxy. Thanks in advance for your help.

Do you have “Always Use HTTPS” enabled in SSL/TLS -> Edge Certificates? I’d imagine if this was enabled, it would not know which non-standard port to redirect to.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.