Client SSL certificate works with Safari and Firefox, but not with Chrome

I’m trying to set up SSL Client certificates. I have installed the certificates in the cloudflare app in SSL/TLS > Client Certificates.
I can successfully connect with curl -v --cert ./device_cert.pem --key ./device_cert_key_cloudflare.key https://myaddressremoved.here
I also managed to install the .p12 which I created from the pem and the key file via openssl pkcs12 -export -out device_cert.p12 -inkey device_cert_key_cloudflare.key -in device_cert.pem in Firefox via the settings and in the OSX key chain (it’s shown in my certificates).
I changed the Trust setting to “always trust” for this certificate in the keychain.
Then I added a Identity preference for https://myaddressremoved.here/* in the keychain.
After that I can access the site with firefox and with safari which prompt me which certificate to use. Choosing the right one grants access to the site.

But chrome doesn’t show me the prompt. Any ideas what to do here?

Update: Found a solution Disable Speed > Optimization > HTTP/3 (with QUIC). After that mtls worked with Chrome too.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.