ClickFunnels and CloudFlare Collab - Not Working for me :-(


#1

I’m working with clickfunnels and it’s been already the third day since I’m trying to set up my custom domain. I followed all the instructions provided and even contacted my registrar. Nothing works. You are my last hope.
I get the endless redirect error.

Should I provide the domain? Well. It’s (http://saleslass.com)

Thanks.


#2

I believe you are using flexible SSL on CF side and because of that your application isn’t aware of schema.
Try this:

  1. Create origin SSL on Cloudflare panel and deploy it on your webserver as HTTPS (port 443) certificate
  2. Change SSL on CF from Flexible to Full (not strict)

I hope that works for you.


#3

@komarEX Hey mate! Thanks for a reply. I’ve tried to issue the certificate but while trying to install it on my registrar it gives this error:

ERROR: The system could not save certificate #1 because of an error: The certificate text was not valid. No valid certificate provided

What should I do? Thanks.


#4

Probably because it is self-signed certificate or because you haven’t provided CA (https://support.cloudflare.com/hc/en-us/articles/218689638-What-are-the-root-certificate-authorities-CAs-used-with-Cloudflare-Origin-CA-).
First try to provide CA and if it doesn’t work contact your hosting support, give them all files (key, cert and CA) and tell them to install this certificate for your site.


#5

@komarEX The instructions at the link are unclear. I’ve contacted support they say it’s beyond their responsibilities. I don’t have a site there just the domain.


#6

Where is your site hosted? Your own server? Some hosting provider? Contact whoever is responsible for that to deploy SSL for your site.


#7

@komarEX No friend. I don’t have a site. I’m using ClickFunnels. I’ve contacted them as well they can’t do anything about it. CloudFlare support is my last resort for finding the solution to this problem.


#8

Is your SSL on Cloudflare panel set as “Flexible” right now? If yes please change it to “Full”.
PS. I’m not aware what ClickFunnels is but I get the general idea of that you are trying to do.


#9

@komarEX Yes, it is on full. If you are interested you may check ClickFunnels.com

Also, the domain registrar said that it’s CloudFlare that manages the Name Servers for this domain

They’ve restarted something over there and it did not help. They said one last thing I can do is contact CloudFlare support so they would restart something (Not familiar with the specific terminology) so it would start working.

Hope it makes sense.


#10

Try to clear all cache on Cloudflare panel but I don’t think this would help.
The main reason why your site does redirect loop is only known to ClickFunnels. Only they can do proper diagnostics why your site/domain behaves likes that.


#11

@komarEX They’ve been footballing me back and forth for over two days and yet they did not found the reason.


#12

I’m sorry but I can’t help you more. As a sysadmin I can assure you that ClickFunnels has all the means to properly diagnose your problem (my clients have similar problems every now and then). If they cannot do that then it either means that you don’t pay them enough so they should spend time on your problem or they are just… not so good with diagnosing things.


#13

@komarEX They said they will investigate the issue. Meanwhile I’ve added a different domain and it works.


#14

I have the same problem - nothing works - just “Your connection is not private” - even though everything in the green. Clickfunnels say that I got unlucky and got a “bad” SSL certificate. No solution yet.


#15

I, too, have a similar problem. When I followed their documentation (Custom Domain Manual Setup Advanced), I didn’t get the results that appeared in the documentation. I contacted Customer Support. The tech told me to “just do such & such” which didn’t help. After 4 hours of support chat, she actually did the modifications and told me everything would be propagated in the next 24 hours. I asked her what she did that I didn’t do, but she never answered me - I didn’t just want a solution, I wanted to know how to do the process. That was 3 days ago, and our domain is still not found on the web. And they have no support staff today. I’m hoping that a CloudFlare tech will be able to help. The domain is FreeYourRetirement.com