Chrome still shows CF-Cache-Status even in development mode

I am in the middle of troubleshooting cache issues with my dedicated server at dreamhost (just move in from somewhere else).
I have put my site under development mode for the past 3 hours. And at the same time, I’m also viewing my website while Chrome Developer Tools is opened and set to Disable cache.
I have been hitting the ‘empty cache and hard reload’ for numerous time to check the updated content.
The main issue i’m having is that my website sometime took up to 10-30 minutes to update the homepage content (we are using wordpress).

And one issue related to CloudFlare is that, why am I keep seeing cloudflare headers in the html response for the whole time? I checked with and it said cloudflare not detected. I even disable cloudflare proxy and put on DNS only mode. Is this Chrome behavior? (My chrome browser is Version 88.0.4324.104 (Official Build) (64-bit))

Thanks for all the help.

The header that I see from chrome developer tool is as follows: (sorry couldn’t put full header because the forum won’t allow me to do so)

Response Headers

  1. cache-control:

no-cache, must-revalidate, max-age=0

  1. cf-cache-status:


  1. cf-ray:


  1. cf-request-id:


  1. content-encoding:


  1. content-type:

text/html; charset=UTF-8

  1. date:

Sat, 30 Jan 2021 11:29:46 GMT

  1. expect-ct:

max-age=604800, report-uri=“

  1. expires:

Wed, 11 Jan 1984 05:00:00 GMT

  1. link:

Development Mode disables caching, but the content still comes through Cloudflare, so CF headers will be visible.

Pause sets the DNS records :grey:, so all traffic bypasses Cloudflare and hits your Origin directly. No Cloudflare headers will be visible.

If you Pause Cloudflare in your account, but still see CF headers I’d start to check that you are actually looking at the correct Cloudflare account. Dreamhost are a Cloudflare Partner. Did you sign up for Cloudflare directly, or via the Partner setup?

1 Like

I had set DNS record to DNS only, but still get CF headers for a very long time, until I close the browser. As long as I have my website page opened (and logged in), and the chrome developer tool opened, the CF is still there.
(But through another browser - microsoft edge, CF is no longer there).
On Chrome, after I close all the browser tab for the website, and left for a few minutes, and re-open, CF is finally gone.

But as for the main issues with cache, I’m still facing problem. I think by setting cloudflare as DNS only, I could possibly ruled out cloudflare as one of the factor.

FYI, my cloudfare account was registered manually years ago, and not through Dreamhost.

Thanks michael

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.