Chrome on PC sometimes showing site as not secure

wordpress

#1

My site is 10thplanetsm.com, and sometimes Chrome on PC is showing it as not secure on my PC, and my managers PC on Chrome is always showing it as not secure (I think).

It is a WordPress site, if that matters. Hosted on Cloudways.

Can anyone please tell me how to fix this? I’d really appreciate it.

Thanks!


#2

Use Cloudflare’s Crypto settings and turn on Always Use HTTPS, and Automatic HTTPS Rewrites.

That should take care of most, if not all, of it.


#3

Thanks sdayman!

I turned on Always Use HTTPS and Automatic HTTPS Rewrites.

Was there anything else you meant that I should do when you wrote “Crytpo settings”?

I’m new to this so not sure if I did everything you meant when you wrote that term.


#4

Nope, those two you changed do a pretty good job of switching everything to HTTPS.

Give it some time to make sure everything is working, then you can experiment with any other settings that interest you.


#5

This topic was automatically closed after 14 days. New replies are no longer allowed.