Chrome force https redirection and sends users in a "too many redirects" error

Hello all!

I have a quite painful issue with Chrome only (for now).
Here’s the situation: for years we had both http and https version of our website crawled by Google, which is obviously bad for SEO. For a few months now, we’ve been cleaning everything, making our https version disappear from Google before making a full and clean switch to https. So we still have both versions, but for now our https version automatically is redirected server-side back to http, in order for Google to empty its entries.

The problem is, now most of the time (not always), Chrome tries by default to open the https version of our site when you visit it, gets redirected to http, but then tries again to redirect to https, generating in the end a “too many redirects” error and sending the visitor into a white page.

So I don’t know what to do to prevent Chrome to automatically redirect to https. I removed the server-side redirection but I need it for the SEO cleaning task. Is there an option in Cloudflare I’m not aware of? Or do I just have to quickly finish our SEO tasks to switch as soon as possible to full https? I need the https version for a subdomain and a subfolder, but not the whole site.

Thanks a lot in advance!
Francois

Yeah having the same issue, if I disable CF proxy it all works.

Hello @l8tr, thanks for your answer!

I saw this topic, but I need the https version for part of our website, I just need to redirect the rest from https to http if https is called, so that I can remove the https version from Google index. I don’t know if I can achieve that, of if I will anyway end up with a redirection loop because of Chrome behaviour.

I tried disabling Universal Cert on CF at the weekend and reissuing but still the same issue occurs.
I just wish I knew why it only happened when routed through Cloudflare.

I am having the same problem. This symptom occurs in Android chrome.

Since August, many users use Chrome are still unable to view my sites.

I am sorry to hear this.

Either secure your website, or contact Chrome developers for some feedback information.

Or make sure to have propererly configured HTTP to HTTPS for further as far as it seems it’s forced by web browsers and I am afraid you cannot do a lot here except as already suggested.