Chrome errors "net::ERR_HTTP2_PROTOCOL_ERROR 200" for static assets - images & CSS


Since earlier this morning, we are getting random Chrome console errors “net::ERR_HTTP2_PROTOCOL_ERROR 200” for static assets loaded by our websites.

When we disable the Orange cloud from the DNS settings and clear the cache, after a few minutes the issues are fixed and the static assets are loaded properly.

The issue is found in various websites in our Cloudflare account

At the moment, I am not sure how to troubleshoot the issue and I am looking for help in order to understand what is going on.

Thank you in advance.



I am also suddenly facing this issue and disabling CF proxy resolves it. May be some new settings was introduced. :expressionless:


Shot you both a DM requesting some info :slight_smile:


The same here, is there any solution??

Hello and thank you for getting back.

I replied to your DM.

Looking forward to hearing from you.

1 Like

We too are having this problem, I’m also available if you need more info.

We have investigating all day long this issue and found different behaviours on different IPs, Locations and networks. It seems related to datacenters. In Cloudflare Status we could not find any clues yet, but it is a big issue on all websites, as randomly correct fonts and images are missing throughout all websites.

So hopefully this gets attention soon as it seems a global problem on all datacenters.

We are also seeing 500 nginx error on our pages but for cloudflare community pages as well. So there might be bigger issues not yet known to Cloudflare.

1 Like

I am suddenly started receiving this error ERR_HTTP2_PROTOCOL_ERROR while in browser content downloading using below sample PHP code:

header('Content-type: ' . $finfo->buffer($content->get('Body')) );  
header('Content-Disposition: inline; filename="' . $doc . '"');
header('Content-Transfer-Encoding: binary');
header('Accept-Ranges: bytes');
echo $content->get('Body');

If I disable CF proxy then it started working. Did CF introduced any new settings which is causing this issue?

Same, here. I investigated further and it looks like cloudflare is swallowing the Content-Length header - which causes this issue on large files. I get this error only on a js file of 987kb.

Attached find the screenshot headers from origin for this file - they include the Content-Length header and then another screenshot of headers from when accessed via cloudflare. (Edit only putting one screenshot since only allowed to post one media for new users)

Btw, if you have HTTP3 enabled in setting this missing header also causes ERR_QUIC_PROTOCOL_ERROR

would be great if anyone from cloudflare can advice on what’s wrong!

1 Like

We are having the same problem. On one application disabling the proxy helped, but on another one the proxy bypass is taking time to apply and so we are currently down.

As said before by abihishiv, the problem seems to be related to the size of the resources loaded.

1 Like

This seems to be a bigger problem which impacts a lot of websites:

Maybe join these threads and getting experts from Cloudflare on this.

1 Like

Hey everyone,

Thank you for the reports! We have identified the issue and are rolling it back
You can follow this issue on our status page here:



The issue is solved now.

Thank you for the quick response.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.