Changes to my website

I downloaded the Free SSL and went to my website. It changed the way my website works and looks. Is there a way to fix?

What did it change? Is it pink instead of blue?

Joking aside. Be more verbose please. Best thing would be to share the domain in question, if possible, or add a detailed error description.

2 Likes

Hi Mark, The website function and look i.e. look for the site. Flexofilmsolutions.com had many different functions and now if I go to the search tab it has a long list and at the bottom it has someone that put Hello World?..LOL…I have No idea. I just looked at my Cert. it has active but incomplete. Maybe that is why all of the changes. If you have an idea on how I could fix it would be greatly appreciated. Thanks,

What’s the SSL mode?

You have mixed content issues. Enable “Always use HTTPS” and “Automatic HTTPS Rewrites” in the SSL/TLS settings.

Mark, I just added the Auto HTTPS. I have not received the completed Activation and it says it could be 24 hours. I noticed the changes to my website already. It has a few changes but hopefully it will fix itself. The Logo is small and not supposed to be. I definitely appreciate your help. Thank you again

Also, I don’t know where to find the SSL Mode. Just FYI. Thanks

You’ll find it here https://dash.cloudflare.com/crypto under the SSL/TLS app.

There hasn’t been activation after my download. What do I need to do to get this?

Hi @rberg, you need to fix the issues with your site in order for it to load securely. It looks like an issue loading a script or css file, based on the small shield with a red x on the chrome address bar:

I was told this isn’t a website issue but, its from something else. Is that true?

{Pii redacted}

Still Mixed Content.

It’s an issue with a resources being called via http when the page is https. On the SSL/TLS app, you can enabled auto rewrites, but that option does not work on scripts or css files. Judging from the small warning shield, it’s a script. You’ll need to edit the code to remove the http call.

I would like to start this over. I need to take the Cert off and do it again. Can’t manage to find help. Please let me know how I can do that. Thanks

Hi @rberg, OK, if you go to the SSL/TLS app and select disable SSL from the bottom that will remove the certificate. It’s up to you, but I don’t know that removing the cert will get you what you want.

Reason being, if you revert the process, you’ll end up at this same point with needing to correct the mixed content errors in those two lines of code:

(index):14 Mixed Content: The page at 'https://flexofilmsolutions.com/' was loaded over HTTPS, but requested an insecure script 'http://flexofilmsolutions.com/wp-includes/js/wp-emoji-release.min.js?ver=5.1.1'. This request has been blocked; the content must be served over HTTPS.
f @ (index):14
(index):1 Mixed Content: The page at 'https://flexofilmsolutions.com/' was loaded over HTTPS, but requested an insecure image 'http://flexofilmsolutions.com/wp-content/uploads/2019/03/logo_large-2-e1553628162472-1024x312.png'. This request has been blocked; the content must be served over HTTPS.
1 Like

It changed my website. All or most of the embedded pictures are gone and it looks generic now.

As @cloonan said, disabling SSL isn’t the correct solution. Here’s a Tip on how to fix Mixed Content issues:

2 Likes

I will try to do that.

1 Like

Will this disable the DNS setting in my GoDaddy account as well?

If you disable universal ssl at the bottom of the SSL/TLS app of the Cloudflare dashboard, that will only change Cloudflare ssl. If your origin server has a valid certificate, that will be unaffected by that change.

But…if you turn off SSL at Cloudflare, and your DNS here is still set to :orange:, then you can’t connect to the site with HTTPS, right? The origin server’s certificate won’t pass through Cloudflare when it’s set to :orange:.

1 Like