Changes not reflecting on site

When a user is logged in on my WordPress website, the changes are reflected.

When a user is not logged in, the changes don’t show.

I am not sure what could be causing the issue here.

Any help would be appreciated.

May I ask you to post and share the URL example to the particular resource in a bracketed dot [.] notation with us so we could double-check, troubleshoot and provide some feedback information reagarding the HTTP cache headers? :thinking:

I wonder which HTTP cache headers are set for it.

Are you using some Website Visual Builder maybe, like Elementor, etc? :thinking:

May I ask if you’re using some custom-made Page Rules at Cloudflare?

Furthermore, may I ask you to check out what option have you got selected by navigating to the Cloudflare dashboard → Caching → Configuration → find section “Browser Cache TTL” and make sure the selected option from the dropdown menu is “Respect Existing Headers”.

Furthermore, from the same menu, click on the blue button saying “Purge Everything” to flush the cache at Cloudflare Edge, just in case.

Wait for a minute or two.

Refresh a page in your Web browser, otherwise try clearing your Web browser cache or use a different Web browser to test out again.

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

You could also determine if this behaviour continues even by using a “Pause” option at Cloudflare as follows:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect
  4. Make sure site is working as expected with HTTPS.
  5. Retry and make sure there are no unknown HTTP cache headers from the origin
  6. Upon success, un-pause

Other helpful articles:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.