Changes in DNS not propagating


#1

I’ve changed the IP for my @ and my www about 20 hours ago now. Previously when I’ve done this I’ve seen the changes take effect within seconds or minutes. Now, not so much. I’ve been doing dns-propagation checks all night and not a single one seems to catch the new address.

Typing in the domain takes me to the 521 error page and then instantly redirects me to the 502 error page. It’s not strange since the server the old IP is linked to is now dead and gone.

I first tried to just swap the values in the existing records, and when that didn’t work I wiped them and re-created the records with my new values. Still no luck.

Am I missing something? Maybe a big red " PROPAGATE DNS SETTINGS " button?


#2

Those records are being proxied by Cloudflare, so we are obfuscating the true origin IP address (which means the public facing IP address doesn’t change). Your target server is not listening on port 443 so Cloudflare is unable to make a connection to the origin server.


#3

Yep, for the first time in a while it Wasn’t the DNS. Whodathunkit.
I removed my old SSL certificates and added some new ones, et voila!

Thanks for the help. It was just what I needed to get my brain working.


#4

This topic was automatically closed after 14 days. New replies are no longer allowed.