Changes from Elementor not Updating

Previously I’m using Bluehost + BunnyCDN and recently migrated my website to SiteGround. I decided to use the free version of Cloudflare and enabled it on my domain. I noticed that every time I do updates on Elementor, it is not updating on the live browser even in incognito mode. That never happened before. One refresh is all it takes for me to see the update on live browser.

So I created a subdomain just to test. Disabled Cloudflare at first, installed Wordpress and then add Elementor. I did some updates on the Elementor and it is updating on the live browser.

At first I tested SG Optimizer since I thought it was the culprit. I enabled each config one by one. Every update on SG Optimizer I also update something on Elementor and refresh live browser. Everything seems fine. Finally, when all configs are enabled and no issue, I then tried to enable the Cloudflare for my subdomain, that’s when the issue persists.

Is there any additional configuration in Cloudflare to let Elementor’s updates applied changes immediately?

Hi,

This looks like a caching issue. Try installing the Cloudflare plugin, enabling the Automatic Cache Management, and see if that solves the issue after each change. If not, try hitting the Purge Everything button after changes. (Alternatively, you may use Cloudflare’s API to purge only Elementor’s CSS files.)

Hi,

Thanks for the respond.

I tried everything you suggested and still the same. Also did the SG Purge Cache but still same result.

What’s your Cache Level at Dashboard > Caching. Also, do you have Page Rules in place?

Caching Level is Standard. No Page Rule.

You can try this to troubleshoot:

(1) purge SG Optimizer cache; then (2) disable SG Optimizer altogether, and remove its .htaccess block if it doesn’t do it automatically when you disable. Then purge CF cache (Purge Everything).

or

Purge SG Optimizer cache; disable all plugins using WordPress’s plugin Heath Check, then purge everything on Cloudflare.

Thank you will try this!

1 Like

Hi

Just tried what you suggested and still the same.
But I did noticed something. Below are additional steps I made.

  • Disabled Cloudflare on my subdomain and waited 5 mins (not sure if important)
  • Deleted the Wordpress installation on my subdomain for cleanup purposes.
  • Reinstalled Wordpress
  • Once login to admin I deleted SG Optimizer completety.
  • Installed Elementor plugin and apply theme
  • Enabled Cloudflare on my subdomain and waited 5 mins
  • Did some changes on Elementor and I can see now changes is applying to live browser. I did it mutiple times and all okay.
  • Reinstalled SG Optimizer. No Changes made on the config just the default Dynamic Caching enabled.
  • Again did some changes in Elementor, all okay.
  • Then enabled Memcached, issue happened again.
  • Disabled Memcached, issue happened again.
  • Purge Memcached, still issue happened.

Does this mean that Memcached has conflicts with Cloudflare?

TBH, I have no idea :grimacing:

While waiting for other volunteers in this community to perhaps make their suggestions, you may want to open a ticket with CF Support (https://dash.cloudflare.com/?account=support, pick last option) and refer them to this topic.

Already send a ticket. Also raised it on SG Optimizer support. Thank you very much for the help appreciate it! :slight_smile:

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.