Changed nameservers two days ago, site barely working and no SSL


#1

Greetings,

I registered two days ago and immediately changed the name servers. Yet I still don’t have SSL and my site opens 1 in 10 attempts on average. What happened?

It is so frustrating, especially since I don’t even have any forms or log in on my site, and from some reason my site got flagged with not secure.

Thanks in advance,
Milos


#2

Hi Milos,

Sorry to hear about your issues. If your SSL :cert: is still authorizing you should be able to switch your account to :grey: to resolve the problems. Once the :cert: is issued you can switch it back to :orange:.

We are working on ways to mitigate these inconveniences. But in the meantime this user posted a very helpful tutorial that might be useful.


#3

Thanks for a quick reply.

I don’t quite understand what the gray cloud represents, so I don’t know what to switch my account to. I’l follow the tutorial you provided and see if I can solve the issue.

EDIT: Okay I figured out what the gray cloud is :). But the things is, my SSL was issued after less then 24 hours, and it still says that it is active. So after switching to DNS only, when exactly should I activate the orange cloud again?


#4

What error message are you getting when the site doesn’t load? Is it Cloudflare branded? Is it the domain associated with the email address you are using to post here?


#6

This site can’t be reached

etnosuvenir.com’s server DNS address could not be found.

That above is what I see everytime I get an error, also it is not Cloudflare branded.
The domain is etnosuvenir.com


#7

I’m not seeing any Host addresses associated with your domain, though WHOIS does point to Cloudflare’s DNS servers.

Do you have DNS entries in the Cloudflare DNS tab?


#8

Frankly, I don’t even know what host addresses are, neither have I tinkered with anything in the DNS tab. All I did after creating a Cloudflare account is was to change the name servers.

Now I also noticed that it says this in my DNS tab: An A, AAAA or CNAME record was not found pointing to the root domain. The etnosuvenir.com domain will not resolve.


#9

A post was split to a new topic: Compatibility with HostGator


#10

I had the same problem :), took me some time before I could see post new topic button. Can’t help with your question though, I’m new with this as well. A month ago I didn’t even know what Cloudflare was, not that I am able to make it work now :).


#11

I was finally able to make my website work while using cloudflare nameservers. But nothing can make SSL work. Is it any easier to set up SSL if I just buy it?

Right now the only error that I can find is when I click on that little globe in Opera, the one that says page information, and then I click on details and get this error: Server’s certificate does not match the URL

I have no idea what that means or what should I do about it. Anyone?


#12

No need to pay for SSL. You (maybe with Support’s help) can get this working.

The good news is I can get a valid SSL connection. Sorta…

The bad news is there’s a redirect loop. It looks like you’re redirecting all requests to HTTPS, which would redirect HTTPS to the HTTPS. Maybe this will help. If not, then it could very well be something in your .htaccess.


#13

I actually tried using the Always use HTTPS in crypto but without success. The thing he explains about Apache and nginx is not clear to me since I don’t even know what those two are.

I’ll activate Always use HTTPS again, maybe it takes some time before it’s applied.

Thanks for your reply.


#14

Update: And now 2 hours after I switched to Always use HTTPS my site is down again.
This is the error: This page isn’t working
etnosuvenir.com redirected you too many times

I really have no idea what else to try.

EDIT: I just read this page: https://support.cloudflare.com/hc/en-us/articles/115000219871-Why-does-Flexible-SSL-cause-a-redirect-loop-

And now I am even more confused. That page says that Always use HTTPS rule should fix the too many redirects problem, but in my case it has caused it.

"If you encounter this, you will need to remove redirects at your origin. Look for RewriteRules in Apache or rewrite directives/301 return directives in nginx and remove them to clear the issue.
This is like alien language to me.

  1. remove redirects? What is a redirect I have no clue.
    2.Apache? Rewrite rules?
    3.nginx? rewrite directives/301 return?

#15

You have Cloudflare set to use Flexible SSL (which means we make an http connection to the origin) but the origin is redirecting our connection to https which results in a loop. Change the Crypto setting from Flexible to Full and that should resolve the issue.


#16

OMG it works. Thank you very much sir, and thanks to everyone in the thread as well.

Great success!