Change the default IP in

The goal is to hide the server IP address with a clouldflare IP. Is it possible to do that with a free plan?

Yes, if the record is set to “proxied”. Note that applies only to HTTP traffic, mail, SSH, FTP and other traffic types need to be set to “DNS only” so will expose the IP address if they are on the same server.

Thank you. The change is not reflecting on whois-domaintools but when I ping the site, it shows the change.

Just to understand better:

If I want a full “anonimity” using a cloudflare IP address, I’ve to set to “proxied” everything in the DNS → Records section?
I need to enable also in DNS → Settings: the DNSSEC and the Email Security ?

Yes, but some things won’t work if proxied, so mail for example needs to be externally hosted and not on the same server as the web hosting or routed through Cloudflare’s email routing service.

Note that there are sites that retain a history of IP addresses for sites (such as so you’d need to change your origin IP addresses or change your host if you don’t want your previous public IP address to be found and used to bypass Cloudflare.

1 Like

ok…so wtf is that Email Security option so?
I really don’t understand why the mail must be on an external server if everything is proxied by cloudflare. I mean how could someone be sure about the real ip of my hosting and mail server using a simple mail (if i’ve proxied everything)

Because Cloudflare only proxies HTTP traffic. If you proxy a mail record, the IP address will point at Cloudflare’s edge servers and then nothing will happen as they won’t accept traffic on the ports or over the protocols used by non-HTTP traffic (unless you use Spectrum).

Email gives away origin servers as mail servers to receive email need to be public (so routing through a mail forwarder can hide your mail server IP address). If you send email from a mail server, IPs will be shown in headers generated by the next mail server it connects to.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.