Change Let's Encrypt SSL to

Hi, my domain have EDGE SSL (Let’s Encrypt). I need to change it to digicert.
I saw the manual Expired LetsEncrypt Root Certificate - #17 by sdayman, but I can’t change the SSL to digicert via API in my Free account. What shall I do?

What API call are you using?

That API - Cloudflare API v4 Documentation
I always have response

    "success": false,
    "errors": [
            "code": 6003,
            "message": "Invalid request headers",
            "error_chain": [
                    "code": 6103,
                    "message": "Invalid format for X-Auth-Key header"
    "messages": [],
    "result": null

Can you share the actual API call you are making. Just redact your email address and API key.

1 Like
curl -X PATCH "" \
     -H "Content-Type: application/json" \
     -H "X-Auth-Email: [email protected]" \
     -H "X-Auth-Key: lkerjljq2lrwelrh123123lqwehr" \
     --data '{"certificate_authority": "digicert"}'

I use Postman.

Hi, maybe someone can help me?

Postman is next on my list of things to learn.

Have you tried command line curl?

The result is the same :frowning:

Hello, tell me please, can I change the certificate on a paid tariff? Very necessary.

I was able to set it with:

curl --location --request GET '<Zone ID>/ssl/universal/settings' \
--header 'Authorization: Bearer <API Token with SSL:edit>' \
--header 'Content-Type: application/json' \
--data-raw '{"certificate_authority": "digicert"}'

Is this your Global API key?

I doubt it. Keys look to be hex only.

Your request is correct. The answer was

Sorry, it was not global API. I tried to send PATCH request with global API key and answer was:

But I can’t change Universal SSL Let’s Encrypt to Digicert SSL. What shall I do?

I found out that this type of certificate does not work with the BY domain zone.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.