Change Host to new IP, can't access website


#1

Greetings,

My website is xixohome.com (wordpress)

My Host provider just give me new IP address, so I change cloudflare DNS setting to new IP. But it give 502 error

After that, I click on Pause Cloudflare on Site, then website can be accessed normally.

Whenever enable Cloudfare, it gives 502 error

What should I do?
Thanks and best regards,
Duc


#2

Pause Cloudflare, wait until it resolves to your actual IP address, and try to check if the new IP address really works.


#3

Yes I have paused Cloudfare, IP address works normally.
Would you mind if I ask how long it should take to resolves new IP address because I have already waiting for a day.

Thank you very much.


#4

Does the new IP address end in 24?


#5

Your domain appears to load fine via Cloudflare

image


#6

Yes, new ip end in 24
I enable cloudflare and it show as image


#7

502 for me, too.


#8

As the earlier screenshot showed it does work via Cloudflare. If it now doesnt any longer you must have changed something server-side.


#9

I guess so, since your screenshot was successful. Curl and Firefox gave me a 502.
36%20AM


#10

Hi,

@sandro: After I paused cloudflare, web can access normally, your screenshot is when I paused cloudflare.
Cloudflare is enable now, would you please recheck again

@sdayman: i had enabled cloudflare yesterday (and will last for next 24 hours). Thats why it shows 502 error.

i’m asking host provider to recheck for me too.

I also appreciate if you can give me some advices.
Thank you very much


#11

I just performed a curl direct to the origin and it returns a 502 error as well.

curl -Ikv https://xixohome.com --resolve xixohome.com:443:your.origin.ip.24 master

  • Added xixohome.com:443:your.origin.ip.24 to DNS cache
  • Hostname xixohome.com was found in DNS cache
  • Trying 125.253.119.24…
  • TCP_NODELAY set
  • Connected to xixohome.com (your.origin.ip.24 port 443 (#0)
  • ALPN, offering h2
  • ALPN, offering http/1.1
  • Cipher selection: ALL:!EXPORT:!EXPORT40:!EXPORT56:!aNULL:!LOW:!RC4:@STRENGTH
  • successfully set certificate verify locations:
  • CAfile: /usr/local/etc/openssl/cert.pem
    CApath: /usr/local/etc/openssl/certs
  • TLSv1.2 (OUT), TLS header, Certificate Status (22):
  • TLSv1.2 (OUT), TLS handshake, Client hello (1):
  • TLSv1.2 (IN), TLS handshake, Server hello (2):
  • TLSv1.2 (IN), TLS handshake, Certificate (11):
  • TLSv1.2 (IN), TLS handshake, Server key exchange (12):
  • TLSv1.2 (IN), TLS handshake, Server finished (14):
  • TLSv1.2 (OUT), TLS handshake, Client key exchange (16):
  • TLSv1.2 (OUT), TLS change cipher, Change cipher spec (1):
  • TLSv1.2 (OUT), TLS handshake, Finished (20):
  • TLSv1.2 (IN), TLS change cipher, Change cipher spec (1):
  • TLSv1.2 (IN), TLS handshake, Finished (20):
  • SSL connection using TLSv1.2 / ECDHE-RSA-AES128-GCM-SHA256
  • ALPN, server accepted to use h2
  • Server certificate:
  • subject: CN=webmail.xixohome.com
  • start date: Mar 14 00:00:00 2019 GMT
  • expire date: Jun 12 23:59:59 2019 GMT
  • issuer: C=US; ST=TX; L=Houston; O=cPanel, Inc.; CN=cPanel, Inc. Certification Authority
  • SSL certificate verify ok.
  • Using HTTP2, server supports multi-use
  • Connection state changed (HTTP/2 confirmed)
  • Copying HTTP/2 data in stream buffer to connection buffer after upgrade: len=0
  • Using Stream ID: 1 (easy handle 0x7ffa55008400)

HEAD / HTTP/2
Host: xixohome.com
User-Agent: curl/7.62.0
Accept: /

  • Connection state changed (MAX_CONCURRENT_STREAMS == 128)!
    < HTTP/2 502
    HTTP/2 502
    < server: nginx
    server: nginx
    < date: Fri, 15 Mar 2019 01:08:15 GMT
    date: Fri, 15 Mar 2019 01:08:15 GMT
    < content-type: text/html
    content-type: text/html
    < content-length: 166
    content-length: 166
    < x-xss-protection: 1; mode=block
    x-xss-protection: 1; mode=block
    < x-content-type-options: nosniff
    x-content-type-options: nosniff

#12

Pay attention to my screenshot and you will notice it wasnt.

Also, the screenshot you posted earlier clearly shows the error originates from your server (check out the server signature).

That issue is not Cloudflare related. First, it did load via Cloudflare as well. Second, you must have made some changes which now throw the error straight on your server. The new .24 address appears to work but there is some other problem.

You need to check your server logs, respectively clarify that with your host.