Change account name in worker url

I’m creating a worker for the first time. The generated URI is https://hello-world-rough-field-a018.{emailName}.workers.dev. Here, {emailName} refers to the part of my email address before the @ symbol. I’d rather not have it like that.

I did go to Manage Account → Configurations and changed my Account Name, but that did not affect the worker subdomain. I am on the paid Worker account ($5/month +).
Suggestions?

Select Workers & Pages from the sidebar in the dashboard. On the right hand side of the Workers & Pages Overview page you’ll see your current subdomain with the option to change it e.g.

Glad that wasn’t a snake!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.