Change A record to @, keeps defaulting to domain name


#1

Hi guys, wondering if you could help? I need to change my A record name to “@” but it keeps defaulting to my domain name… any Ideas how to get this done?


#2

@ is shorthand for example.com. It’s supposed to do that.


#3

hey, thanks for this - so change to example.com and that will do the same thing as @?


#4

Well…not “example.com”, but what your real domain is.

Is something not working?


#5

sorry for the uneducated questions! I’m trying to update my A and C records to use a new format from the company that runs my website. my current site is running fine but to transition to the new format they’ve asked me to update the CNAME with has worked fine and then to change the name value in the A Record to @… does this sound right? I’m a bit lost, have been working on this for a while… thanks so much for your time with this!!


#6

An “A” records needs a hostname, and an IP address. Documentation usually says to enter “@” for hostname so they don’t have to explain that you need to type in your actual domain name.

Did they give you an IP address for that “A” record? Put that in and that should do it.


#7

thanks, yeah they gave me an IP address which is correct but still not working…
they’re asking for this:


and my DNS looks like this:
It all looks good to me…
thanks again!


#8


#9

Looks like it’s working to me. Next step would be to see if your site host can install SSL for your website.


#10

yep this is current site is working but to change to the newer format from the provider they have asked me to change settings to the above, its just a newer format they are using, they’re holding a new site on their end - all of my info/pics have been migrated just need to get the dns to point there…


#11


#12

Now I’m a little confused. You posted directions with an IP address and a CNAME, and posted a picture of your DNS that matches their instructions.

Yet it’s not looking how you expect it to look. Correct?

Maybe to simplify troubleshooting, can you switch those two DNS entries to :grey:? That will take Cloudflare’s proxy services out of the equation.


#13

switch them to “cloud”? sorry, how do I do this?


#14

In your DNS picture, both entries are set to :orange:. Click the cloud and turn both to :grey:.


#15

great, ok done now - you think this will sort it out? if so I’ll get back in touch with portfoliobox


#16

You’ve done what they told you to do. With those entries set to :grey:, they should be able to troubleshoot this. Once that’s working the right way, you can set them back to :orange:.


#17

ok, thanks so much. I’ll see how I go with them.