CF not serving precompressed Brotli from origin

Hi,

I’m doing Brotli and Gzip precompression of all my files on the server. Server serves files in the order Brotli > Gzip > Uncompressed. I want to serve my Brotli files because they are much smaller (compressed to the max on the server).

However due to some reason CF do not request Brotli files from my server, it requests only Gzip versions.

What I’ve done:

  • I’ve disabled all services mentioned at https://developers.cloudflare.com/speed/optimization/content/brotli/content-compression/#notes-about-end-to-end-compression
  • Tried to configure “Configuration Rules” to disable mentioned services for all requests
  • Tried to set “Cache-Control: public, no-transform” header on the origin as described at https://developers.cloudflare.com/cache/concepts/cache-control/#examples
  • Tried to enable/disable Brotli compression
  • Cleared Cache and so on

No matter what I do, Cloudflare never request Brotli-compressed files from my origin. It either serves Gzip version or perform it’s own Brotli re-compression.
Disabling CF proxy completely works and I’m getting my Brotli files directly from origin, but I don’t want to disable CF proxy.

According to CF blog from this summer https://blog.cloudflare.com/this-is-brotli-from-origin/

Compression Rules are available now! With End to End Brotli being rolled out over the coming weeks.

Related forum post https://community.cloudflare.com/t/upcoming-change-to-accept-encoding-header/517115 is also already closed.

Does anyone knows when we can expect this feature to be enabled?

Thanks.

The feature was disabled. Look into the linked thread for updates.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.