CF Keeps redirecting http to https

Hi Cloudflare Community.

In SSL => Edge Certificates: I’ve disabled “Always Use HTTPS” and “Automatic HTTPS Rewrites” but it keeps me redirecting from http to https. I don’t have any redirects set on my nginx server, what could be wrong about it?
This is all because we have problems with AutoSSL Certificates renewals…

Thanks in advance,


Are you seeing these redirects on Chrome (or other browsers)? Does your site also redirect if you use the curl command? Most visitors using browsers will be redirected from http to https by the browsers themselves, as they’ve recently enabled a forced redirect when domains have a specific DNS record (all Cloudflare websites using Universal SSL do). Requests from AutoSSL shouldn’t be affected, though.

1 Like

Redirects happen both in browsers and curls. The curls i make on port 80 show in the end: location on https://
Its rare tho what happens with AutoSSL, true, shouldn’t be affected.

Have you hit Purge Everything since you’ve disabled AUH?

1 Like

Even after hitting Purge Everything curl still shows https redirection. I am missing something extra i have to setup?

You need to check your Cloudflare and origin setup to see what is causing this redirect. Page Rules, Redirect Rules etc.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.