CF IPV6 connection timeout

questions: CF CDN cannot access my source site via ipv6.
I used ipv6 as source ip of CF cdn,and it shows error code 522 and I found no inobond connection.
IPV6 direct:Success
IPV4 direct:Success

Nginx keeplive:ON
Iptables:ON,and allow every IPV6 traffic In/Out
ufw:disabled tunnel

user www www;
worker_processes auto;
error_log /www/wwwlogs/nginx_error.log crit;
pid /www/server/nginx/logs/;
worker_rlimit_nofile 51200;

use epoll;
worker_connections 51200;
multi_accept on;

include mime.types;
#include luawaf.conf;

	include proxy.conf;

    default_type  application/octet-stream;

    server_names_hash_bucket_size 512;
    client_header_buffer_size 32k;
    large_client_header_buffers 4 32k;
    client_max_body_size 50m;

    sendfile   on;
    tcp_nopush on;

    keepalive_timeout 60;

    tcp_nodelay on;

    fastcgi_connect_timeout 300;
    fastcgi_send_timeout 300;
    fastcgi_read_timeout 300;
    fastcgi_buffer_size 64k;
    fastcgi_buffers 4 64k;
    fastcgi_busy_buffers_size 128k;
    fastcgi_temp_file_write_size 256k;
	fastcgi_intercept_errors on;

    gzip on;
    gzip_min_length  1k;
    gzip_buffers     4 16k;
    gzip_http_version 1.1;
    gzip_comp_level 2;
    gzip_types     text/plain application/javascript application/x-javascript text/javascript text/css application/xml;
    gzip_vary on;
    gzip_proxied   expired no-cache no-store private auth;
    gzip_disable   "MSIE [1-6]\.";

    limit_conn_zone $binary_remote_addr zone=perip:10m;
	limit_conn_zone $server_name zone=perserver:10m;

    server_tokens off;
    access_log off;

listen 80;
listen [::]:80;
listen 443 ssl http2;
listen [::]:443 ssl http2;
index index.php index.html index.htm default.php default.htm default.html;
root /usr/local/ServerStatus/web;

#error_page 404/404.html;
if ($server_port !~ 443){
    rewrite ^(/.*)$ https://$host$1 permanent;
ssl_certificate    /www/server/panel/vhost/cert/;
ssl_certificate_key    /www/server/panel/vhost/cert/;
ssl_protocols TLSv1.1 TLSv1.2 TLSv1.3;
ssl_ciphers ECDHE-RSA-AES128-GCM-SHA256:HIGH:!aNULL:!MD5:!RC4:!DHE;
ssl_prefer_server_ciphers on;
ssl_session_cache shared:SSL:10m;
ssl_session_timeout 10m;
error_page 497  https://$host$request_uri;


#error_page 404 /404.html;
#error_page 502 /502.html;

include enable-php-00.conf;

include /www/server/panel/vhost/rewrite/;

location ~ ^/(\.user.ini|\.htaccess|\.git|\.svn|\.project|LICENSE|
    return 404;

location ~ \.well-known{
    allow all;

location ~ .*\.(gif|jpg|jpeg|png|bmp|swf)$
    expires      30d;
    error_log off;
    access_log /dev/null;

location ~ .*\.(js|css)?$
    expires      12h;
    error_log off;
    access_log /dev/null; 
access_log  /www/wwwlogs/;
error_log  /www/wwwlogs/;


This text will be hidden
#communitytip 522 error

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.