Cf-cache-status: MISS! Help!

Answer these questions to help the Community help you with Security questions.

What is the domain name?

MEEKU < . > CA

Have you searched for an answer?


Please share your search results url:

cf-cache-status: MISS


Describe the issue you are having:


What error message or number are you receiving?

What steps have you taken to resolve the issue?

  1. Removed ALL caching plugins.
  2. AHHHH! I don’t know what is going on!

Was the site working with SSL prior to adding it to Cloudflare?


What are the steps to reproduce the error:

  1. Go to, inspect network on

Have you tried from another browser and/or incognito mode?
Yes, everything.

See attached.

I’m sorry, I’m not sure what you are asking. Do you want to help me or not?

I get a HIT first time but you probably don’t want to cache the admin bar across the top.

1 Like

Hmm, this is interesteing.

I’m not even sure how you are getting the admin bar, because it’s bypassed.

Do you still get it?

You are bypassing the admin URL but the admin bar is on the front page of your site. You can disable the bar all together in WordPress settings or just turn on development more when you’re working on the site and purge the cache after you’ve logged out.

@shawn11 this is a bug, that appears when you have SXG activated. Can you please make sure, you have SXG disabled and then try again?

1 Like

I’ve disabled the SXG, and now receive a cf-cache-status: DYNAMIC

Any Suggestions?

Then this is your real cf-cache-status. This SXG bug atm forces MISS and therefore overwrites what it truly is - which is DYNAMIC for you. This btw also is the default at Cloudflare, since it by default does not cache HTML.

To enforce caching it, you have many options:

  1. Cache Everything
  2. APO (just for Wordpress)
  3. Workerbased caching (you have to do it on your own)
  4. If the site is static, you can use Cloudflare Pages.

Since you seems to be using Wordpress, I would strongly recommend APO.

1 Like

Thanks for this information Martin.

I’ve had issues with APO in the past since my host uses Varnish. Whenever I would do updates and purge, I wouldn’t see the updates properly (even with developer mode on).

Super Cache for Cloudflare seems to do the worker cache automatically, but again I was having issues with caching etc.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.