Cf-cache-status: MISS after changing settings in the litespeed cache

Hi, i am new to Cloudflare and i have a problem.
CF-cache-status: Miss
Yesterday I changed a few settings in the lightspeed cache and I purged everything in Cloudflare Caching. And since then Cloudflare doesn’t seem to have saved my website files on their server. I have removed all settings on that plugin, but the result is the same.

My response header:
cache-control:no store, no-cache, must revalidate
cf-cache-status:MISS

I manually edited the cache-control in the htacess file, but cf-status still Miss.

My response header now.

  1. cache-control:

public, max-age=2628000

  1. cf-cache-status:

MISS

  1. cf-ray:

519bb4d4b83edd02-SIN

  1. content-encoding:

br

  1. content-type:

text/html; charset=UTF-8

  1. date:

Sat, 21 Sep 2019 11:30:19 GMT

  1. expect-ct:

max-age=604800, report-uri=“https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct

  1. expires:

Mon, 21 Oct 2019 21:30:19 GMT

  1. pragma:

no-cache

  1. server:

cloudflare

  1. status:

200

  1. vary:

Accept-Encoding

I don’t have a lot of programming knowledge so seems like I did something wrong.

Everything worked very well until yesterday.
What should i do now?

Thank in advance

Possibly that. But do you always get a miss or only on the first attempt? The latter would be by design.

Also, without actual links it is close to impossible to give proper advice.

Hi Sandro
I always get a miss.
You can check: https://freevideoeffect.com/

After the first load I immediatey get hits on Cloudflare.

Can you give me the screenshot?
I check it on GTMETRIX and Pingdom, but the result is the same

$ curl -I https://freevideoeffect.com/wp-content/cache/autoptimize/css/autoptimize_dfce9760e17af2ab605ccc065b8e8ed3.css
HTTP/1.1 200 OK
Date: Sat, 21 Sep 2019 12:00:17 GMT
Content-Type: text/css
Content-Length: 237983
Connection: keep-alive
Cache-Control: public, max-age=30669813
Cf-Bgj: minify
Cf-Polished: origSize=238218
Expires: Thu, 10 Sep 2020 11:23:50 GMT
Last-Modified: Sat, 21 Sep 2019 01:04:49 GMT
Vary: Accept-Encoding
X-Turbo-Charged-By: LiteSpeed
CF-Cache-Status: HIT
Age: 2187
Accept-Ranges: bytes
Expect-CT: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
Server: cloudflare

The important part is what your connection says. What does your browser show?

so What about freevideoeffect.com response header ?
Why CF-Cache-Status: MISS

That was most likely the first attempt. And it does not answer the question about your browser.

I set a page rule
Cache Level: Cache Everything.

Please reread Cf-cache-status: MISS after changing settings in the litespeed cache. It does refer to the most likely reason why your main page does not get cached.

For the sake of clarity :wink:

I am trying to delete Pragma, can you guide me to delete it?

You need to do that on your server. Somewhere in the configuration.

I deleted Pragma in response header but the result is still the same.
Did you find anything else?

Your server appears to send an Expires header, dating to 1981.

In htacess file:

EXPIRES CACHING

ExpiresActive On ExpiresByType image/jpg “access 1 year” ExpiresByType image/jpeg “access 1 year” ExpiresByType image/gif “access 1 year” ExpiresByType image/png “access 1 year” ExpiresByType text/css “access 1 month” ExpiresByType text/html “access 1 month” ExpiresByType application/pdf “access 1 month” ExpiresByType text/x-javascript “access 1 month” ExpiresByType text/css “access plus 1 year” ExpiresByType application/x-shockwave-flash “access 1 month” ExpiresByType image/x-icon “access 1 year” ExpiresDefault “access 1 month”

Did I do something wrong? I didn’t find the expires header as you said.

not 1981

Must be somewhere else then. We are a bit beyond the forum’s scope now however. I’d take this to Reddit or StackExchange.

Thank you so much for taking the time to help me.

I appreciate it.