Cf-cache-status is always HIT even after I purchase everything in cache

Hi,

Now I find a very strange thing. The cf-cache-status always returns HIT even after I do the following things:

  1. Purge everything in the cache in cloudflare.
  2. Wait 30 seconds
  3. Close all Chrome instances.
  4. Start Chrome
  5. Clear the Chrome cache manually.
  6. Start a Incognito window in Chrome and visit our website.

See below:

I have also tried to reduce Edge TTL from 14 days to 30 seconds, but still not working. The status is always HIT, unless I press Ctrl+F5 to send a cache-control:no-cache in the request header, which will force the response returns with cf-cache-status as BYPASS.

Why?

Perhaps it’s because someone else is visiting your website earlier than you?

I think that is impossible, because:

  1. I just count 30 seconds with a stopwatch and then make the test immediately.
  2. I try from different locations, such as India, USA, all get such a result.
  3. I try many times.
  4. My site is a light site and I choose the time when there only be 2 to 3 visitors.

I also make more test, and find a strange thing. I purge the cache and then use stopwatch to count to 31 seconds, and then load the page, and get the following result:

I notice that the age is 24 seconds. So it seems that whenever I purge the cache, the edge server will cache the content immdiately.

I still believe someone visited your website faster than you, especially if you have a high traffic site.

I make a test. I use password generator to generate a URL with 50 characters, as below:

nrbjcjfrrrajepjvvqjcbypmiabidjccizufyheybsrirdwsab

Then create a new page and set its URL to https://www.example.com/nrbjcjfrrrajepjvvqjcbypmiabidjccizufyheybsrirdwsab/

Thus I believe no one will be able to know this page and visit it.

When I load it in Chrome for the first time, I still get the cache status as HIT, as below:

Why?

Are you using Pages or is this site hosted by yourself/a third party?

Have you used any Rewrite rule in the Transform Rules section?