Cf-cache-status: DYNAMIC when using workers to cache

cf-cache-status: DYNAMIC is even when workers is used, tried creating my own worker but same result.

I tried using this plugin

And this code

But cache is not hit

are you logged in or sending a nocache directive (usually the default in chrome dev tools)?

Also, the KeyCDN tool might be sending a nocache directive. What happens if you visit the site on a browser with dev tools and disable cache unchecked?

2 Likes

Another issue with KeyCDN and other tools is that they set an accept header of */*, whilst the worker checks specifically for “text/html” (line 61 of the worker). This primarily affects bots and automated test tools, which miss the cache because they’re missing that text/html in the accept header.

2 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.