CF-Cache-Status: Dynamic, APO is not working

Hi Team,

I have purchased APO and integrated it with my wordpress site. Also have the CF plugin which says APO is turned on. But when I do the analysis with uptrends or redbot, the cf-cache-status is dynamic and not HIT. I have WPRocket plugin, which I tried disabling, clearing the cache (WP & CF) and tried again.

Always the result comes back Dynamic which to me means it is not working.
Any help in getting this setup is much appreciated.

My site is


It looks like you’re using Kinsta, and they have their own caching configured. I recommend you contact Kinsta and ask them if APO is compatible with their hosting.

1 Like

Can we do something clear with rules to bypass the Kinsta and enforce APO?

Also, looking at the headers from redbot, it shows

CF-Cache-Status: DYNAMIC
cf-edge-cache: cache,platform=wordpress
ki-cache-type: None
Ki-CF-Cache-Status: BYPASS

So looks like Kinsta cache is bypassed, but APO is not working properly?

And there is no cf-apo-via in the header either.
Checked with Kinsta, they said it should work fine as they have other sites working fine, example

Does the Speed → Optimization part of your dashboard show that APO is enabled and active on that hostname?

I have fixed it now, thanks

What fixed it?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.