CF APO & Woocommerce

Hi,

I have Free Clouflare for a WP website using woocommerce. I have issues with the basket update and it comes from the caching of content. So I installed the wordpress Automatic Platform Optimization (APO) and purchased for 5$ per month because it is said it bypasses those caches. But the issue remains.

Does anyone know why ? Is APO my solution or should I cancel and just add some page rules to bypass manually ?

Thanks !

Emma

Cloudflare APO should be compatible with WooCommerce plugin for WordPress at least as seen on the “compatible list” here:

What issue do you have regarding the basket update? Could you please share your domain/Website with us so we could try to inspect some code, errors, console, or at least try to replicate the issue which you have too, if so?

Saying you cannot update your cart right?

  • I just assume, when the cart is being updated (via Ajax requests), and if cache works, it should only cache the “product page” and hopefully by default “bypass” the cart itself …

Have you tried setting up some settings at the Cloudflare dashboard regarding the APO being “enabled”?

Which version of APO are you using at your Website?

Webiste is https://inaluna.com

I am logged in as a customer, and each time i add or remove, the number on the cart changes but the content doesn’t.

I am using the last version, i just installed it

I don’t know which settings you mean

Could you provide us some information if the Website and cart were working good before you have added your domain to your Cloudflare account?

On your Website, there are some Content Security Policy ("script-src") errors showing up to me, if that could be also related to some issue in further investigation.

The thing that happens to me is:

  • When I add a product to a cart, it is successfully added - cart (1).
  • When I add more products, again, all are successfully added to the cart - cart (4).
  • When visiting cart page, number is (4) within the car-icon, but the cart is empty.

Moreover, I got 403 XHR error returnet for the request https://inaluna.com/?wc-ajax=wc_stripe_get_cart_details with the value of -1.

As if you are using cPanel and Apache, is there a way to temporarly disable/turn off the mod_security option in cPanel?

Could this link below be related to this topic?:
https://wordpress.org/support/topic/wc-ajaxupdate_order_review-403-error/

Maybe this way here can help a bit solving your issue too. Give it a try:
https://wordpress.org/support/topic/wc-ajaxupdate_order_review-403-error/#post-9653485

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.