CF APO on WordPress - Not working - "cf-cache-status: DYNAMIC"

Trying to get APO to work with no success… I’ve got the CF Pro Plan.

CF plugin is enabled in WordPress as it shows:

Note: APO runs against the following list of hostnames:
mysite.pro, www.mysite.pro

  • Using Kinsta.com (Nginx) for hosting
  • Kinsta’s server-level caching enabled (default)
  • No caching plugin in WordPress front-end
  • Have re-installed the CF plugin multiple times
  • Flushed cache on both Kinsta and CF multiple times

As you can see in the attached image, cf-cache-status, shows “dynamic” instead of hit.

Been stuck here for the last couple of days…

Without knowing the actual domain, we can’t poke around for more info. We’re there any more headers? I’m trying to see if there are any cookies involved.

Sure.

Thanks!

Do you also have APO enabled at dash.cloudflare.com in Speed → Optimizations? Probably since you’re seeing that message in the dashboard.

My only guess is that the Kinsta cache is interfering with operation. Is there a way to disable that?

It is enabled in CF dash. Kinsta has a server-level cache which doesn’t cause a problem with CF.

If nothing seems to work, open a ticket and post the number here. @yevgen will most likely take a look at it.

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

p.s. As a final thought, would you happen to be using Kinsta’s built-in Cloudflare configuration?

Not using Kinsta’s built CF config as Kinsta doesn’t support APO yet. Opened a ticket with CF. Ticket#2142621

Thanks!

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.