CF Access - Service Auth, no "Token" option?

While securing a web application behind Access, API calls are made to the backend, which cause them to be intercepted by Access and fail due to being routed to auth page.

I need to issue a Service Token and add them in the headers to the client-side fetch() requests, but I don’t seem to have the option to create them at all.

Unsure of how to proceed, outside of re-writing the entire application so that the data is hydrated server-side rather than client-side.

From what I know the Tokens option is available only on paid plans. You need to upgrade your Access subscription.

1 Like

Ah, I see. Is a paid Access plan separate from the plan for the domain it’s under/the plans here?

Not sure I can see at first glance where I could pay to enable this.

I believe the upgrade is in the Teams’ Dashbord (where you had the first screenshot). It’s confusing, I know. The teams knows, will hopefully get better.

1 Like

Oh, gotcha! It’s https://dash.teams.cloudflare.com -> Account -> Billing -> “Plan”, right?

Really appreciate the rapid response!

1 Like

After upgrading to 10 users at the standard plan, the option still isn’t there :slightly_frowning_face:

Hopefully I can track down a support email for the Cloudflare folks because I’m a bit blocked at the moment until I can get around this issue.

It may take a moment, but… to contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

1 Like

Hi there - Would you mind trying to log into the Teams dashboard via an incognito window?

Hopefully, by doing this we can identify why you aren’t able to see https://dash.teams.cloudflare.com -> Access-> Service Auth -> Service Tokens

3 Likes

:woman_facepalming:That was it. Should have thought to try that first in retrospect. Appreciate the support + response, will close out the ticket I had opened as well.

Thank you!

2 Likes

No problem at all. Always happy to help :slight_smile:

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.