Certificate verification failed

Dear CloudFlare,

My domain is hosted on FastComet. I used the FastComent to create the CSR and the got it signed from CloudFlare. Now when I am installing the certificate I am getting error -

The certificate could not be installed on the domain “digitalnorth.in”.

  • ![error|16x16]
    Certificate verification failed! The system did not find the Certificate Authority Bundle that matches this certificate. Contact “CloudFlare, Inc.” to obtain the Certificate Authority Bundle for “CloudFlare Origin SSL ECC Certificate Authority”.

Any idea where things have gone wrong.

Regards,

Sumit {pii redacted}

** HERE IS THE UPDATE **
So after technical chat with my hosting provider “Fastcomet” and opening discussion in the CloudFlare Community including open ticket directly with CloudFlare, could find any satisfactory answer. I decided to do all the steps again.

So, this may work if you using FastComet CPanel otherwise I just leave for you to read.

So in SSL/TSL under Security in CPanel - I deleted everything that was there earlier including Private Keys and created then Generate a Private Keys and New Certificate Signing Request.

Once done.

Then I went to CloudFlare and deleted earlier SSL that was created. Now I copied my own CSR and it gave me the signed certificate back, which then I added into upload new certificate in Cpanel. The only change I did between last time and this time is when generating CSR i did not gave Passphrase this time.

And Vola!! when I went ahead to do the certificate installation. The CABUNDLE was already pre-filled and all did was to click on install and it went all OK ! Done and Dusted.

Hope it works for you. If not then let me know and I will try to help you with my level best.

Regards,

Sumit

You have self-signed cert on your origin server and ssl/tls is set to Full (Strict), that combination won’t work, can you set ssl to Full on the overview tab of the SSL/TLS app on the Cloudflare Dashboard?

(BTW, Full (strict) is the most desirable setting. To use Full (Strict), you’d need to get a proper certificate on the origin such that it loads https without cloudflare, from there, set up cloudflare and set to Full (Strict) for end-to-end encryption.)

This is exactly the error I am getting and yet no solution is visible.

I have been able to resolve the issue. Deleted everything and created everything again in my cpanel of my hosting provider fastcomet.