Certificate status is stuck in Pending Validation tried both http and txt validation

I have added 10+ custom domains in Custom Hostnames and all were validated within a few hours, This particular domain has not getting validated for more than 48 hours,

I tried with http validation as well as txt validation but both are stuck in pending validation

This domain appear to be unhappy. The owner should contact their registrar / DNS provider.

https://dnsviz.net/d/swagrani.com/dnssec/

1 Like

I tried with another new domain but it still not getting validated
this domain swagrani.in is new just bought yesterday

swagrani.in

Now you have a domain with CAA records that don’t appear to allow wildcard issuance of a certificate from Let’s Encrypt at the root. IIRC that’s the default CA used for Cloudflare for SAAS.

❯ dig swagrani.in caa +short
0 issuewild "letsencrypt.org"
0 issue "globalsign.com"
0 issue "digicert.com"
0 issuewild "globalsign.com"
0 issue "letsencrypt.org"
0 issuewild "digicert.com"
0 issuewild "comodoca.com"
0 issue "comodoca.com"
2 Likes


These are the default CAA records in the DNS

There are no default records in DNS… your current DNS provider may have added some for whatever reason, but a default DNS Zone has zero records in it. And as I mentioned the record that exists for let’s encrypt is an issue vs. an issue wild. You will need to change that so that a certificate for gallery can be issued.

3 Likes

Removing CAA records for let’s encrypt will solve the issue?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.