Certificate is valid but browser says not secure


recently , chrome is giving me a warning that my site is not secure.
i have checked my cloudfare’s ssl and they are valid .
ssl checkers show i have a valid certificate.

the website in question is https://leatherforpets.com

whats wrong ?

thank you

i dont get image errors like you mentioned , just a warning " not secure ". No other information of what is not secure , but i do think it has to do with images.

where in my cloudfare dashboard is there a setting to enable ssl for images? under ssl /tls , there is nothing regarding images

thanks again

You get that not secure, because you have insecure links and you need to apply the fixes mentioned in the article.

what article you mean ? you posted a screenshot i believe before but it does not show

i see only this

" [image] or [image] If you see this error, you should enable: [image] in the SSL/TLS app [Screenshot%20from%202019-08-27%2013-47-34] "

Ehm, that’s not a screenshot.

For example you are trying to load http://www.gstatic.com/youtube/img/email/avatar_720.png. So it might be your Google integration.

you got that link from my page?

Otherwise I wouldn’t say you are trying to load, would I? :wink:

Seems to come from Youtube, if you block the Youtube integration the mixed content disappears. That might be a question for Google as that won’t be anything you can control if that link comes from Google. You could only try #5 from Community Tip - Fixing mixed content errors

problem fixed
it was the youtube video causing it

thanks :slight_smile:

This topic was automatically closed after 30 days. New replies are no longer allowed.