Certificate active but website "not secure"

Hey!

I just created my website www.spardhaangra.com
I signed up to cloudflare and my certificate shows active but the website is still not secure.

Can anyone help?

You have mixed content issues…

Hey!

I checked and installed the SSL Insecure Content Fixer plugin. It still does not work.
I am unsure as to what the problem is.

Have you tried going though the whole list…?

Hey!

Yes. I made the changes from flexible to full. Even changed the TLS from 1.0 to 1.2 as it showed an error on whynopadlock.com
I rechecked my website it shows no errors on there but it is still marked as “not secure”.
I believe when you have mixed content it shows the “info” icon instead of the “warning” icon right?

Have you enabled the Automatic HTTPS Rewrites?

Yes I have.

You also don’t seem to have a valid certificate on the origin as it now fails to do an handshake with the origin.

1 Like

Hey!

Can you explain this in laymen’s terms?
Sorry not a pro :confused:

I’m sorry, but there is nothing easier to explain :frowning:

The certificate on your server isn’t a valid certificate, hence it fails to connect correctly with Cloudflare. You need to either lower the security from Cloudflare (setting SSL to at most Full) or, better, add a valid certificate on your server.

Me too the same problem. I have changed my webname, enabled in cloudflare but website still show non secure… Can anyone help???

My w/ebsite is www.leangiap.com

Shows correctly for me. If you still see issues open a new topic.

1 Like