CDN not working with Wordpress

Hi, I am trying to set up my Wordpress website with Cloudlfare CDN but when I switch on with Swift Perfomance plugin the images, css, js is not loading at all. Or do I have to add something into my Server DNS for this domain? I am using SSL on my server.

Here are my Cloudlflare DNS:
https://www.screencast.com/t/KeCn161nsi5

My Swift CDN:
https://www.screencast.com/t/rpxqfkrK

Can you please help me? Thanks

Regards
Mike

It could be that you need to :grey: that CDN entry in your DNS page. Having it set to :orange: adds an extra layer to what should already be an efficient CDN setup.

Can you be more specific? Where and what? Thanks

On the Cloudflare Dashboard, there is a DNS settings section for your domain (see picture below).
Each entry can have a :orange: or :grey: (or nothing). For that cdn CNAME entry, make sure it’s set to :grey:

I did this but still the same. Please check here this is the website: https://myfurvest.com/

because you have error NET::ERR_CERT_COMMON_NAME_INVALID for example: https://cdn.myfurvest.com/wp-content/themes/shoptimizer/assets/css/main/main.min.css you will need to fix it

How can I fix this? Can you help me please?

It would be easier to turn off your plugin’s CDN option since you’re already using Cloudflare’s CDN.

when I turn off CDN in Swift performance plugin the CDN is not loading at all on the site. All images, css, js ,is loading over the server. Any help? Thanks.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.